package Flextable sur RStudio

Added by Armelle Gion over 4 years ago

Bonjour,

J'utilise Rstudio et RMarkdown et j'ai besoin du package Flextable. Je n'ai pas trouvé d'autres alternatives pour la mise en forme des tableaux en sortie word.
Je n'arrive pas à l'installer, et il semblerait que ce soit car la version de Rstudio sur dga20 est trop ancienne.

Serait-il possible de remédier au problème afin de pouvoir utiliser ce package (qui peut être utile à d'autres personnes) ?
Ou de me dire quoi faire ?

Merci d'avance,

Armelle


Replies (6)

RE: package Flextable sur RStudio - Added by Thierry Coudert over 4 years ago

Quelle est la version de R utilisée pour la tentative d'installation ? pas celle de rstudio

RE: package Flextable sur RStudio - Added by Thierry Coudert over 4 years ago

le package flextable vient d'être installée pour la version 3.5.0 de R sur dga20

RE: package Flextable sur RStudio - Added by Armelle Gion over 4 years ago

Merci !
On vient de charger la library, on va tester.

Bonne fin de journée,

Armelle

RE: package Flextable sur RStudio - Added by Armelle Gion over 4 years ago

Le package en soit fonctionne dans Rstudio, par contre il y a un message d'erreur lors de la compilation pour générer le document word :
Error in knit_print.flextable(x,...) : pandoc version >= 2.0 required for flextable rendering in docx Calls

Apparemment il faut une "pandoc version" supérieure...
Il y a moyen de faire quelque chose ?

Merci,
Armelle

RE: package Flextable sur RStudio - Added by Thierry Coudert over 4 years ago

La version 2.9 de pandoc vient d'être installée sur dga20. Par contre, je pense qu'il faudrait la tester hors rstudio-server , donc à partir de la commande R350 depuis dga20.

Pour la faire prendre en compte par rstudio-server, il faudra surement faire un arrêt-relance

RE: package Flextable sur RStudio - Added by Armelle Gion over 4 years ago

En arrêtant et relançant Rstudio, ça fonctionne très bien !

Merci,
Bon week-end,
Armelle

(1-6/6)